Jump to content

loosebiker

Supporting Member
  • Content Count

    57
  • Joined

  • Last visited

Community Reputation

12 Good

About loosebiker

  • Rank
    2000 MM venture # 158
  • Birthday 07/10/1937

Personal Information

  • Name
    Bob Grissett

location

  • Location
    Rome, United States

Converted

  • City
    Rome

Converted

  • State/Province
    GA

Converted

  • Home Country
    United States

Converted

  • Interests
    motorcycles/fishing
  • Bike Year and Model
    2000 venture millenium

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. I blead my rear brakes on 2000 venture now the bleeder screw will not close. Has anyone had this problem? If anyone has dealt with this how did you fix it.
  2. I have a tow-Pac Trike kit on my 2000 MM. Handles great. It all depends on getting them lined up rite. I have had no problems of any kind. It handles and steers very well. My tow pack has been on the bike for 3 yrs and over 30,000 miles.
  3. I have a tow pay kit on my 2000 MM and I love it. I have not had any problems at all.
  4. You can beat this. The Lord has brought me thru 3 fights with cancer. The Last time was Nov 2013.
  5. Thanks for all the advise. I finally got the old oil seal out. That metal band was still on the shaft. Putting the drive shaft back in was a real PIA. I had the bike serviced and the rear end splines serviced at 16000 miles. When I took the drive shaft out of the bike at 32000 miles I found a paper towel that than been folded and put under the universal joint to hold it up. This by a mechanic with 30 yrs experience.
  6. Sorry. I have a 2000 MM venture. My oil seal was destroyed so I have to replace it. My problem is that I cannot get it to go on the shaft. Part #is right for my bike.
  7. Does the driveshaft oilseal need to be pressed on. I am having trouble getting my oil seal to slide up on the shaft going into the pumpkin. I took the drive shaft out to grease both front and rear splines and the new seal will not go on the collar. Thanks
  8. Thanks for all the replys. After checking the fan I think the armature is going bad. I only here the noise when the fan starts up and again when it stops.
×
×
  • Create New...