Jump to content

malenurse13

Expired Membership
  • Posts

    35
  • Joined

  • Last visited

Reputation

22 Excellent

Personal Information

  • Name
    Andrew

location

  • Location
    Vivian, LA, United States

Converted

  • City
    Vivian

Converted

  • State/Province
    LA

Converted

  • Home Country
    United States

Converted

  • Bike Year and Model
    2000 Yamaha Royal Star Venture
  1. The temp has been 102 the last couple days. I've got a 45 min commute to work (mostly interstate). The last 2 days, when I pull up in the parking lot, I can smell antifreeze. These are the times when I wish I could see the engine temp like I could on my last 5 motorcycles. The bike is not leaking any coolant that I can see. It's not smoking. I don't feel any change in performance. Is there any way I can find out if the motor is running too hot? What would y'all do if you smelled antifreeze after a long, hot ride??
  2. I pulled my gas tank off the other day, did a few things, and put it back on. Then I found this on my garage floor!! I looked in the manual and I can see where it goes... But what is it for??
  3. So if this means there's too much oil... Do I need to drain a little? Or can I assume any extra oil has already came out and leave it till the next oil change??
  4. Just so you know... I wiped off most of the oily residue before taking the picture. But you can still see how wet it is on the left side.
  5. I pulled the gas tank off yesterday to install the 2nd Gen RSV Ignition By-pass Relay from djh3. First time I've had the tank off. What I noticed was a TON of oily residue on the left side, under the tank. Any idea where this is coming from and what I need to do to keep it clean??
  6. I installed some LED lights under the frame of my Venture. I think I need to put some under the gas tank too. Looks weird with lights under the bike only. Also installed the 2nd Gen RSV Ignition By-pass Relay from djh3.
  7. I've purchased the parts for Earl's Gen 2 clutch kit. I've got all the instructions. I've seen a few youtube videos with Venture rider's installing one of those new Barnett springs. But I just bought the thicker clutch diaphragm spring. Does anyone know where I can find a video or detailed pics showing each step of the installation process? I want to make sure I'm prepared before I break or lose something important. Thanks!
  8. I've already asked a few questions about this but haven't fixed it yet. When riding at night, my headlights fade in and out at random times. And the lights on the gauges do the same thing. It all happens at the same time. When the headlights dim, the gauges do the same. When the headlights get real bright... the gauges do the same thing. I've checked and clean every ground connection I can find but the problem is still there. So my question is... Is this Ignition Bypass Relay something that might fix this?? Ignition By-pass relay for 2nd Gen RSV
  9. I commute about 40 miles to work and another 40 back. 1/2 my commute is interstate and I run anywhere between 75 and 85mph. So 40 miles a day, I'm running around 80mph. Maybe that's why I can't get any better than 30mpg. I guess that's the reason for the humongous engine sizes we see on cruisers and touring bikes today. I'm still happy with the bike. At least I know when I need to fill up.
  10. It looks like it's been at least 7 years since the last good discussion about Gas Mileage. I've got a 2000 Venture with BUB Exhaust. I just bought it so I'm not sure what kind of air filters or if any re-jetting was done when exhaust was installed. But I'm only getting around 30 mpg! Now, I noticed from several old posts that 30 mpg is actually normal for some of these bikes. But I also noticed some claimed to have over 40 mpg on theirs. What kinds of things can I look for or change to possibly improve gas mileage. I have to turn the pet-cock to reserve after about 140 miles. I really thought I'd get better gas mileage than that...
  11. That's what I did... works great now! Thanks!
  12. I'm posting a link to djh3's ignition bypass. I may want to order one of these too... Ignition By-pass relay for 2nd Gen RSV
  13. On my way home last night I noticed my 2 running lights wouldn't turn on at all. The red switch in the front fairing on the left side wouldn't light up when I turned it on. So I'm assuming there's no power to the switch at all. I'll be pulling off the gas tank this weekend to clean all connectors and check all the grounds. But what should I take apart and look for to fix the running lights? Could it be a fuse??
  14. I've changed the oil. Previous owner said it was last changed last year! I got both running lights working up front. That clutch is slipping pretty bad though. That'll be my next investment. Gotta wait till my birthday next month tho...
  15. Well, I didn't have this forum with me when I went and bought some new oil. Here's what I got. What do y'all think??
×
×
  • Create New...