Jump to content
IGNORED

Isolation relays


Recommended Posts

Trying to help a fellow with an Eluder, he wants to add running and turn signals to the front forks, he has found that if the turn signal circuits are connected directly to the LEDs he purchased there is a constant drain on the battery, even with the ignition off. Sounds crazy to me, but he has troubleshot it out so I believe he is correct.

So my question is , what have other forum members used for isolation relays to turn light circuits on and off. 

I have used isolation relays for my trailer harnesses, but they are currently unavailable due to part shortages, I have already recommended the isolation relay from EC that they used for their trailer harnesses, but both EC's offering and my traditional go to device are expensive for what he needs to do.

I am looking for a proven product, suitable for LEDs that does not break the bank.

Thanks

M61A1MECH

Link to comment
Share on other sites

Hi Steve,

I can't answer your question but do have one of my own.

I purchased some cheap led panels that fit into the front/rear reflectors. They have two circuits. I attached power directly to running and turn signals. No parasitic drain. Installed on my 89 VR and the 2005 RSV. 

What gives with the Eluder? Or is it the LEDs?

 

Link to comment
Share on other sites

4 hours ago, videoarizona said:

Hi Steve,

I can't answer your question but do have one of my own.

I purchased some cheap led panels that fit into the front/rear reflectors. They have two circuits. I attached power directly to running and turn signals. No parasitic drain. Installed on my 89 VR and the 2005 RSV. 

What gives with the Eluder? Or is it the LEDs?

 

Dave,

It is a mystery to me, makes no sense, but there is a resistor in line with each LED that maybe that knocks  down any parasitic draw, he tapped into the circuit between the ECU where the signal comes from and the resistors. He did find a 5mV charge on the lines, but that bled off quickly with just the meter load, so I chocked that up to capacitance in the wires.

Not knowing what is going on inside the ECU I really can not offer any rational explanation.

I thought maybe he had left the key on in the accessory position, but he said the bike alarms if the ignition is left on for a few minutes and he was sure he would have noticed the ignition switch in anything but the OFF position when he came back to it the next day.

He and the bike are in California and I am here in Florida, so I have no one on one with the bike and no knowledge of the bike's systems beyond what I read in the schematics.

I cannot believe the LEDs would be the issue.

We have selected a small encapsulated relay that has two normally open contacts, he is going to wire them in so they come on and close the contacts when the ignition is on and let the bike send the turn signal power to the added LEDs through the closed contacts.

Should work, he will let me knows once they are installed.

What puzzles me is he cannot be the first rider to try an add addition signal lights to the front of an Eluder and I just built a system for him that connects the rear turns, running and brake circuits to a Harley style tour pack, that all worked just fine, tapped into the rear lights just as you would for a trailer harness but without and isolator, that has been installed for over a week with no issues.

Here is for hoping the isolation relays do the trick.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...