Jump to content
IGNORED

Just got an 1984 Venture Royale 1200 - She's in need of Carburator help and WAS starting on choke only before I cleaned it - old gas too.


Recommended Posts

It's GOTA be running on 3 still. While it was idling I checked exhaust heat and we're indeed back to 1/2 heat on the left side. 

I'm just gonna replace all the coils and go from there. I think probably at high RPM there is more voltage and is jumping the gap. She has NO PROBLEM at high RPM. I feel like I lose spark at low RPM.

Also I totally put a Needle in backwards! Dope! 

  • I can only get her started with quick start.
  • I have the idle adjusted to what you can hear.
  • BOGS on throttle rev
  • Once it picks up it definatley revs too high and eventually comes back down
  • If I cover the airbox with my hand for a second she revs up, which I am assuming is right and she is just sucking more gas like a choke

I THINK I'M CLOSER!!!!

Link to comment
Share on other sites

Posted (edited)

Still having some trouble. I've replaced 3 coil packs and for sure, I think there has been improvements. 

But now the battery is dead again and I must wait until morning... sigh.

I was concerned about top right coil pack and replaced it, look at the beast go now. It doesn't appear to be 'as frequent' as the other sparks, they're like spark spark spark -- this one is like spark,,,,spark,,,,spark -- that matter?

image.png.4036cf698bf9ee7a8fc2ab8f728592d4.png

Edited by Solace
Link to comment
Share on other sites

Are you bench synced?

Did you set all the idle mix screws to the same start point?

Did you ceck to make sure all of the idle mix screw parts are there and installed in the correct order?

Did you set the fuel level in the bowls?

I would also hghly recommend relocating the CDI to the top of the air box when you replace the coils. It will be much cooler and more protedcted from the elements there.

I would also recommend updating the fuse block.

Keep in mind also, these bikes will not run right with air box open. They will idle, kind of, but bog and choke with any throttle. 

Hanging throttle, stuttering/bogging on wind up, back fire on decel are all indicators of the carbs being out of sync. Of course they can also indicate other problems, but the sync is the most likely culprit.

  • Like 1
Link to comment
Share on other sites

SUCCESS. 

Well guys, thanks for your helpful tips on this bike. WHAT A FINNICKY MONSTER SHE WAS! By far the most touchy engine I've worked on (5+). Super interesting.

I need to get that 4th air mixture screw loosened, she's stuck good, but the other carbs are making up for it. The power is getting there, she will live on!

Link to comment
Share on other sites

New plugs! 

We are at the final stages; I think it's just carb tuning now. I haven't noted that ALL 4 of the air pistons/needle thingies were moving, now all 4 are moving! Also the bike sounds crazier, and yeah kinda like a sewing machine!

However I need quick start to start, won't idle -- yet. Any tips? 

Link to comment
Share on other sites

Ive gotten it to here adjusting the air mixture screws INWARD they're at about 1.5 turns on 3x of the carbs, but that last carb is just seized up and I have no idea what position it is. 

Smoke is just from crap on the metal I think, I degreased it. Burning it off. I hope.

Link to comment
Share on other sites

9 minutes ago, Solace said:

Synchronized? All the butterfly flaps are in perfect sync.

Ill have to do another test make sure we’re on 4

You are still missing on one cylinder sounds like. It's time to sync the carbs to get a better handle on things. You can't sync by looking at the sliders, you'll need a sync tool for that, as well as setting the idle mixture screws properly.

Link to comment
Share on other sites

So we can say the spark plug is working, it’s got spark, but the carb is totally messing up and it’s not igniting the cylinder while the other 3 are?

Link to comment
Share on other sites

Posted (edited)

That idle mixture screw needs freeing up.  Was it stuck when you disassembled the carbs? 

Idling way too fast usually means a vacuum leak.  I would suspect a leak between the carbs and the engine, the "manifolds" or carb holders.  

Edited by BlueSky
Link to comment
Share on other sites

OK guys here's a comp video of my Venture running on 2, and now I'm not sure if she is on 3 or 4. But there's an improvement.

I had to order some tools to extract the stuck air mixture screw. Guess I'll work on the ATV until that arrives!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...