Jump to content
IGNORED

Best place to mount a WOLO Bad Boy horn on a Gen 1????


Recommended Posts

I picked up a WOLO Bad Boy horn and relay for the '86 today. Has anyone mounted one on a Gen 1? If so where did you place it?

 

I'm thinking I'll just fab up a mounting bracket that runs straight back from the OEM mounting point and mount the WOLO unit in the recess of the lower fairing next to Cyl. 4

Link to comment
Share on other sites

I made a bracket that mounted to the frame right where the horn does. Made it long enough to hang the horn outside the lower fairing leg. When I added combo fog/driving lights I made new brackets that carried those too.

 

You should put a horn on each side. Really gets you noticed.

Link to comment
Share on other sites

I mounted my driving lights to the original horn brackets, I mounted a Bad Boy on each side to the saddlebag crash guards. I used purchased chrome handle bar mounts to make the attachment. Worked great. 2 is better than one. I started with one and then a year later I upgraded to a second one. I ran them both off the same relay so it was really easy to add the second one.

 

If I had not sold the bike I was going to upgrade to train horns, a tank and a compressor running at 200 PSI.

Link to comment
Share on other sites

  • 2 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...