Jump to content
IGNORED

2005 RSTD Headlights stopped working ignition switch getting hot


Recommended Posts

ok so I know the headlight switch is bad as the lights were working when switching high/low back and fourth then they stopped working, noticed key was hot when I pulled it out of the ignition, so pulled chrome cover off the ignition and let engine run ignition got too hot to hold your hand on it after 20 min of engine running , pulled headlight switch apart and found one of soldered 3 wires that go to the actual headlight switch button had broke off tried resoldering low beam light came on but after switching to low/high beams nothing....so this is sounding very expensive so far but I think my pain is self inflicted as a little over a month ago the key was sticking when trying to turn the ignition so like a moron I sprayed WD-40 into the key hole of the ignition guess I'm am getting what I deserve for being so stupid!!.

Edited by Raven1294
Link to post
Share on other sites

Pinwall cycle should have those parts used. Look up the parts new at a online yamaha parts dealer and then compare if used is worth a shot. Pinwall typically has the miles that were on the bike when it was salvaged. Also check the harness where the ignition switch plugs in. Could be high resistance on that plug, but if all the heat is in the switch, its likely high resistance in the switch contacts more than likely. CRC makes a contact cleaner safe for plastics. You could try that with some air and see if flushing the WD 40 out helps. check all the wiring and connectiosn between the ignition switch, high low and the head light.

 

Edit: After reading your other post it seems you have some bad/problematic wiring from the prior owner that may also be causing you issues. Does this bike have Passing lamps, aka Driving lights, also? depending on what those are and how they are wired, could be causing too much load on the headlight circuit. More and better pictures may help get it sorted out.

Edited by RSTDdog
Link to post
Share on other sites

Well it seems the damage has been done, it seems I have to disconnect the battery as the ignition switch is getting very very hot even with the engine off now :( wil the contact cleaner drain out if I spray it into the ignition switch, does it have a way to flush out the wd-40 an exit so to speak?

Link to post
Share on other sites

I would look into inspecting the switch. There is a post in the 2nd gen tech about how to fix/clean the switch. If you cant find it let me know I have it saved on the other computer. Also look at the 2 pin plug under tank and make sure it isnt melted. The driving lights is a good place to look for issues too. The "factory" way to wire those is not a good way IMOP.

Link to post
Share on other sites

Do you all think it would be safe to drive it to the dealership? Its about 15 miles from my house so about a 30 min drive, I know it will really be expensive but just don't have time to mess with it and I have the money to get it done and a great certified Yamaha mechanic to do it just want to make sure I'm not going to cause more damage if I drive it there....Thanks

Link to post
Share on other sites

Not looking to hijack the OP's thread (maybe it might even help him) but just wondering...

Is there a way to bypass the ignition switch as far as the lighting system goes? (eg could a relay be installed that runs the lighting via the switch & therefore puts less current through the switch)

I understand it's a pretty common problem & something that really Yamaha designers really should have known better or perhaps even published a fix for what appears to be bad design. Maybe someone here has already done the mod?

Link to post
Share on other sites
Not looking to hijack the OP's thread (maybe it might even help him) but just wondering...

Is there a way to bypass the ignition switch as far as the lighting system goes? (eg could a relay be installed that runs the lighting via the switch & therefore puts less current through the switch)

I understand it's a pretty common problem & something that really Yamaha designers really should have known better or perhaps even published a fix for what appears to be bad design. Maybe someone here has already done the mod?

 

Well sort of. Yamaha for some reason draws the power thru the switch kind of. When you turn the key it sends all the power thru the switch. Bad thing is the contacts get hot and melt/fry/arc. So I built a plug and play relay that send the load thru a relay when the switch is turned on, vs all the amps running across the contact points.

Link to post
Share on other sites

RSTDdog thanks for the advice using the contact spray it worked! now the switch doesn't get hot anymore, was able to drive it to the dealer and my mechanic said he would install that bypass harness I had purchased from djh3 once he try's to repair the headlight switch and ignition swich he is also going to take all those taps off solder and heat shrink them and make sure no issues anywhere else.....thanks for everyones thouights on this issue.

 

Robert

Link to post
Share on other sites
If at all possible never use those scotch lock things. They end up causing sooo many issues later.

 

 

 

 

No problem there, I have never used them and never will...... everything will be soldered and heat shrunk, one of the 4 owners before me did that handy work.

Link to post
Share on other sites

What the relay does is keep like 20+ amps of power from arching across some small switch contacts. To run the passing lamps what I did was run them off a fused power from battery thru a relay. You could pull key on power from the relay, but the actual power for lights I would find or make direct power from battery with some 14ga wire.

Link to post
Share on other sites
What the relay does is keep like 20+ amps of power from arching across some small switch contacts. To run the passing lamps what I did was run them off a fused power from battery thru a relay. You could pull key on power from the relay, but the actual power for lights I would find or make direct power from battery with some 14ga wire.

 

 

Thank you sir! Going to get all this done up right!

Link to post
Share on other sites

ok so all the wires with the taps under the seat and in the headlight bucket have been soldered and heat shrunk and direct run for the passing lamps with fuse to battery, headlamp switch has been repaired and cleaned bypass harness installed I got from djh3 all corodeded connectors cleaned or replaced everything seems to be working fine but after riding about 30 miles the ignition switch was hot again and stayed hot still after 1.5 hours, today here in Texas while I was riding was about 99F, any thoughts? replace Ignition switch? don't know what else to do....Thanks

 

Should the ignition switch get hot at all or should it be cool to the touch no matter how hot the temp may be outside?

Edited by Raven1294
Link to post
Share on other sites

Hmm Dont know as I can give you an exact answer. Frankly I'm surprised you have a TD and are having switch issues. They typical dont have the issues as the RSV does because just simply dont have the draw of current. Did you actually take the switch apart and clean/file/sand the contacts? I cant say as I ever grabbed a hold of my ignition switch to see how hot it was.

Link to post
Share on other sites

No the switch itself was not taken apart and cleaned but all the wiring after everything was done tested good, maybe someone out there after riding their bike for awhile can see if the switch gets pretty warm after riding it, you can put your finger over the key hole and should feel if its hot, I took the chrome plastic cover off and it was pretty hot holding your fingers over the cylinder of the switch, fact is it may have always been hot since I bought it, but after using the contact cleaner and spraying into the key hole an using compressed air to spray it out I rode it with the chrome cover off and it never got hot after a 20 mile ride at 95F maybe the switch gets hot with the chrome cover on it.

Link to post
Share on other sites

So last night I sprayed contact cleaner into the key hole again and then used compressed air to blow it out, this morning 80 to 85F rode for about an hour and switch was cool to the touch, this afternoon it will be close to 100F and will ride for another hour and seen if it stays cool or gets hot again, this morning and this afternoon will be in stop and go traffic.

Link to post
Share on other sites

ok no issues today or so I thought rode the bike a bunch today in hot weather and the switch stayed cool all day got home this evening turned the bike off checked the switch and it was cool to the touch, about 45 min later I go out into the garage and check it and the switch is really hot! So rolled it out of the garage and within a few min it started to cool down, while I had it sitting in the garage it stayed very hot to the touch for 2 hours then once rolled out it, it cooled quickly even though it was still very warm outside.

Edited by Raven1294
Link to post
Share on other sites

So the last two tests you did was the cover on or off? With the key off and sitting in the garage was the cover on or off? I don't own an rstd any more, but what is right below the switch, I don't remember? Is the top of the tank there or something else? Is whatever is directly below the ignition switch hot too? If it was cool when you parked it and got hot after sitting for 45 minutes after riding, my guess is heat soak. Heat rises, so the heat from the exhaust pipes and front head are rising up and around the tank. when you are riding and air is moving, it keeps the switch cool. Pushing it outside, any breeze, even warm breeze will dissipate heat better than no air moving in garage.

 

Try this; make a heat deflector out of some HD aluminum foil, not for when you ride it, but when you park it. Go for your test ride, do what you normally do then when you park it put the heat deflector under the ignition switch somewhere the idea being divert the heat from the engine and exhaust. If the switch doesn't get hot or as hot, the switch is getting heat soak from the engine after shut off.

Link to post
Share on other sites

Well, this is interesting. Far as I remember switch is bolted to frame and tank sits around it. I guess heat from engine could rise and create some heat. But this is getting crazy.

Link to post
Share on other sites

That is exactly what I was thinking but should the swith get as hot as the engine itself as just holding my finger over the key hole gets so hot I can only keep my finger on it maybe for 10 seconds before it is too hot, seems to happen after a 30 min ride when the temp is up close to 100F other then that is never gets hot I ride it to work every morning about 4 miles then home for lunch and back to work and it never gets hot, so far it has happened twice since I got all the electrical issue fixed both times after sitting in the garage for 45 min, so maybe somehow it is heat soak.

 

 

The cover was on

Edited by Raven1294
Link to post
Share on other sites

Funny thing is when the switch gets hot nothing around the switch is hot not even the radiator cover after sitting for an hour, so I think the switch may have gotten damaged some how due to all the bad wiring someone had done on the bike.

Link to post
Share on other sites

I thought the mod djh3 makes takes all the headlight load off the ignition switch and puts it through a relay? Should not leave much draw through the switch itself other than the fan. I know a mechanic did the wiring for you. Have you checked that the battery cables and grounds are all clean and tight? Ground at the battery and where it bolts to the frame? 4 mile ride to work probably doesn't get the bike hot enough to turn the fan on. You need to find someone with a DC amp clamp. seems like something is still pulling a load through that switch.

Link to post
Share on other sites

Strange thing is even after a long ride in stop and go traffic 97F + it isn't hot after arriving home, ignition switch is cool it slowly gets hot after sitting awhile which leads me to believe it must be heat soak, because if it was a load on the switch it should be hot after getting home, there is no other real explanation.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...