User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: front end wobble

  1. #1
    Join Date
    Jun 2013
    Location
    West Palm Beach, FL
    Posts
    203
    United States
    West Palm Beach
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)

    Default front end wobble

    My Venture and I are new friends and the more time we spend together the more I seem to notice THINGS. If I sit on the bike holding it centered and quickly shake the bars left to right then stop stop my motion the front end seems to wiggle back and forth on its own a bit. I don't notice any wobble when riding. My Road Star doesn't do this.

    I stopped at the dealer, and was told that the antennas were causing it, it was normal. Am I paranoid? Is this normal?

  2. #2
    Join Date
    May 2007
    Location
    Waller
    Posts
    14,741
    United States
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Mine does it also, but it was more so when I was running a CT on the rear, this was caused by the soft side walls. Check you air pressure in your tire, are you running a CT? Your dealer is a Moron!!



    Quote Originally Posted by gez View Post
    My Venture and I are new friends and the more time we spend together the more I seem to notice THINGS. If I sit on the bike holding it centered and quickly shake the bars left to right then stop stop my motion the front end seems to wiggle back and forth on its own a bit. I don't notice any wobble when riding. My Road Star doesn't do this.

    I stopped at the dealer, and was told that the antennas were causing it, it was normal. Am I paranoid? Is this normal?

  3. #3
    Join Date
    Jun 2013
    Location
    West Palm Beach, FL
    Posts
    203
    United States
    West Palm Beach
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by Kregerdoodle View Post
    Mine does it also, but it was more so when I was running a CT on the rear, this was caused by the soft side walls. Check you air pressure in your tire, are you running a CT? Your dealer is a Moron!!
    I've owned this a month now, purchased with 17k miles, I've put 3k miles on it and the Dunlop D404s. Pressures are 40 psi front and rear, I ride alone 95% of the time. I'll need new tires soon. Thinking of the Elite IIIs.

    I stopped at the dealer because the PO told me that the warrantee ended the end of this month. Wrong! I have anything I can't handle done at an independant shop. Thanks for your response.

  4. #4
    Join Date
    Oct 2012
    Location
    Brooksville
    Posts
    1,759
    United States
    FL
    Post Thanks / Like
    Mentioned
    14 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by gez View Post
    I stopped at the dealer, and was told that the antennas were causing it, it was normal. Am I paranoid? Is this normal?
    I would NEVER take my bike to a place that tries to convince me its the antenna and that its normal?? Really? What's next, the cassette player is the reason why the bike has 0.9 gal on its reserve? Wow...

    As for the PSI... I also run 40/40 as per suggestion from these fine folks and have had better overall handling. I am sure someone can come up with a few ideas for your original problem. Your added issue is to find a new shop...

  5. #5
    Join Date
    Jun 2008
    Location
    Halifax
    Posts
    2,307
    Canada
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by gez View Post
    My Venture and I are new friends and the more time we spend together the more I seem to notice THINGS. If I sit on the bike holding it centered and quickly shake the bars left to right then stop stop my motion the front end seems to wiggle back and forth on its own a bit. I don't notice any wobble when riding. My Road Star doesn't do this. I stopped at the dealer, and was told that the antennas were causing it, it was normal. Am I paranoid? Is this normal?
    Must be some heavy duty heavy weight antennas on that bike to be able to do that! impressive..

    however, if you have the means to raise the front of the bike off the ground, you may want to check your neck bearings in addition to the recommendations of the other responders. (if you don't know what to check for, you will be checking for any clicking / clunking in the neck as you pull forward and backwards on the tire, if it clunks, it's loose and needs tightening. There are several write ups in the tech library how to check all of this and the fixes etc)

    If such is the case, the quick fix is simple, the big fix is more involved.. but still easily done at home..

    Best of luck.

  6. #6
    Join Date
    Jan 2008
    Location
    Lugoff
    Posts
    14,819
    United States
    SC
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default

    If you were hitting flying monkeys with the antennas, then maybe.
    Spray WD40 on the antennas and move on to another dealer.

    Edit: re read you post. This happens at stop, like in the carport. Yeah, neck bearing loose?
    Else, fold the antennas down and try again. (They have a sleeve you can loosen to drop them for covers.)
    Last edited by Mike G in SC; 07-11-2013 at 04:00 PM.

  7. #7
    Join Date
    Oct 2006
    Location
    Holbrook
    Posts
    327
    United States
    MA
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Well taking the dealers answer into consideration I believe it may be caused by those small ball located at the top of the antennas. What may be happening is because the weight of the balls and the length of the antennas they tend to start a pendulum motion and that transmits down the antenna and to the bike causing the bike to sway accordingly much like a metronome does.

  8. #8
    Join Date
    May 2010
    Location
    Tichborne
    Posts
    2,856
    Canada
    ON
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)

    Default

    Mind you ,......I have a first gen.....

    I replaced the neck bearings, (progressives...although that doesn't really relate) and put a Condor super brace on as well. Everything is tight and shipshape.
    BUT.....when I'm stopped and give the bars a shake back and forth, I get the same kind of "Echo" shake.

    The members here just re-assured me that because we are talking about 2 tubes about 3 ft long with a joint in the middle, the front end WILL have a bit of flex or twist movement and it is normal.

    It rides just fine ....so no problem!

Similar Threads

  1. Front End Wobble
    By luke000 in forum Venture and Venture Royale Tech Talk ('83 - '93)
    Replies: 13
    Last Post: 04-14-2013, 06:55 AM
  2. Front end wobble
    By Glenson in forum Royal Star and Royal Star Tour Deluxe Tech Talk
    Replies: 8
    Last Post: 07-17-2012, 02:40 PM
  3. Front End Wobble
    By GlennTuc in forum Honda Goldwing Tech Talk
    Replies: 25
    Last Post: 01-23-2011, 12:52 PM
  4. Front End Wobble
    By Tom in forum Royal Star Venture Tech Talk ('99 - '13)
    Replies: 12
    Last Post: 11-09-2008, 10:31 AM
  5. Front end wobble
    By Locomotive in forum Venture and Venture Royale Tech Talk ('83 - '93)
    Replies: 9
    Last Post: 06-26-2007, 01:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •