User Tag List

Likes Likes:  0
Results 1 to 5 of 5

Thread: Test failure on a front bush

  1. #1
    Join Date
    Dec 2019
    Location
    Leeds
    Posts
    14
    United Kingdom
    WY
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Test failure on a front bush

    Hi folks,
    Yesterday I took the 92 XVZ1300 for it's annual test here in the UK and it failed due to the bushes on the swingarm support bracket (the very front pivot section that joins onto the swingarm itself where the shock mounts) being too worn.
    As you may know parts here in the UK for my bike are very difficult to get hold of.
    A question....is the swingarm set up on the XVZ1200 the same as the set up on the XVZ1300? i.e. will the bushes on the 1200 fit the same as the bushes on the later 1300?
    Can anyone point me in the right direction of a supplier of the bolt (possibly 90101-12578), bushes (90381-20069) and collar (90387-144H4-00) over with you guys in the States.
    Just read in the service manual that it's the bushing on the RELAY ARM that I'm talking about.
    Also I see that repair doesn't look so daunting after all. Mufflers off, shock out a few other bits and that's it. I don't have a ramp and I suppose it's how easy the bolts come out after nearly 30 years. Anyone had experience of doing this job??
    Thanks,
    Your UK cousin , Blake
    Last edited by Dales venture; 06-27-2020 at 06:20 AM.

  2. #2
    Join Date
    Aug 2006
    Location
    Brantford
    Posts
    9,547
    Canada
    ON
    Post Thanks / Like
    Mentioned
    126 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Test failure on a front bush

    Check out the following phish(s).
    https://www.yamahasportsplaza.com/oe...89c0/swing-arm
    https://www.yamahasportsplaza.com/oe...972b/swing-arm

    There are a lot of parts discontinued, but you might find what you need, other than that, you'll have to get some made up.
    Suggest to put grease fittings in all the joints, to prevent this from happening again.
    Gonna miss all you guys and gals
    at the

    Rally @ T h e S h o r e s
    July 16-19th 2020



  3. #3
    Join Date
    Dec 2019
    Location
    Leeds
    Posts
    14
    United Kingdom
    WY
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Test failure on a front bush

    Thanks for that but it's easier finding rocking horse **** than it is finding someone to manufacture bearings around here.
    I can't believe bearings are so hard to find?
    It's easier to find bearing for my 79 XT500 than it is for a 92 Venture!!
    By the way there is a grease nipple on the shaft of the relay arm but previous owners have no doubt forgotten about it.
    Regards,
    Blake

  4. #4
    Join Date
    Aug 2006
    Location
    Brantford
    Posts
    9,547
    Canada
    ON
    Post Thanks / Like
    Mentioned
    126 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Test failure on a front bush

    Gonna miss all you guys and gals
    at the

    Rally @ T h e S h o r e s
    July 16-19th 2020



  5. Thanks Dales venture gave thanks for this post
  6. #5
    Join Date
    Dec 2019
    Location
    Leeds
    Posts
    14
    United Kingdom
    WY
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Re: Test failure on a front bush

    Thanks for that. I've sent the guy a message to see if he'll post to UK.

Similar Threads

  1. How Deeply Do I Install The Fork Slide Bush and What Loctite for Damper Bolt?
    By Bob K. in forum Venture and Venture Royale Tech Talk ('83 - '93)
    Replies: 2
    Last Post: 08-28-2018, 08:08 PM
  2. All systems failure on car.
    By Dragonslayer in forum Watering Hole
    Replies: 15
    Last Post: 07-31-2017, 11:31 PM
  3. RM Stator failure
    By Props in forum Venture and Venture Royale Tech Talk ('83 - '93)
    Replies: 8
    Last Post: 08-03-2009, 09:14 AM
  4. Possible coil failure?
    By Beau-Kat in forum Picture Folder
    Replies: 3
    Last Post: 07-20-2008, 11:22 AM
  5. Rate of failure?
    By RustyRecycledToy in forum Venture and Venture Royale Tech Talk ('83 - '93)
    Replies: 3
    Last Post: 09-19-2007, 03:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •